summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfiregore2016-02-11 16:32:29 +0100
committerfiregore2016-02-11 16:32:29 +0100
commit1b7748bba02abee5395208354ac0801292fdb571 (patch)
tree0be11cc2e78371c11b38e3b0cc227173c421020b /PKGBUILD
parentd0fcf6e7572b78b1e84b9bea94c6a625586789c7 (diff)
downloadaur-1b7748bba02abee5395208354ac0801292fdb571.tar.gz
Added Brotli Compression Support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb7392945be6..e956bf499f31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,9 @@ _pkgname=nginx
provides=('nginx')
conflicts=('nginx')
pkgver=1.9.11
-pkgrel=1
-pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, mainline, with Naxsi, Certificate Transparency, GeoIP (GeoIP Legacy) mYubiKey Auth Support builtin and with Thread Pools.'
+pkgrel=2
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, mainline, Brotli
+Support, with Naxsi, Certificate Transparency, GeoIP (GeoIP Legacy) mYubiKey Auth Support builtin and with Thread Pools.'
arch=('i686' 'x86_64')
url='http://nginx.org'
license=('custom')
@@ -30,6 +31,7 @@ source=($url/download/nginx-$pkgver.tar.gz
#https://github.com/pagespeed/ngx_pagespeed/archive/release-$_psver.zip
#https://dl.google.com/dl/page-speed/psol/$_psolver.tar.gz
git+https://github.com/nbs-system/naxsi.git
+ git+https://github.com/google/ngx_brotli.git
git+https://github.com/sanderv32/ngx_http_auth_yubikey_module.git
#git+https://github.com/aperezdc/ngx-fancyindex.git
git+https://github.com/openresty/headers-more-nginx-module.git
@@ -78,7 +80,8 @@ build() {
--add-module=../ngx_http_auth_yubikey_module \
--add-module=../naxsi/naxsi_src \
--add-module=../headers-more-nginx-module \
- --add-module=../nginx-ct
+ --add-module=../nginx-ct \
+ --add-module=../ngx_brotli
make
}