summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfiregore2016-02-04 16:02:55 +0100
committerfiregore2016-02-04 16:02:55 +0100
commit93b06864fe709a59b521b59535c2050ee815d5c0 (patch)
treeba392accd459a79419837cd61e0204ebea07fc93 /PKGBUILD
parent9ce8f12eb3f359a31ce07788a30cacf9d3458092 (diff)
downloadaur-93b06864fe709a59b521b59535c2050ee815d5c0.tar.gz
Updated for Nginx 1.9.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 16 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57b97e70585b..83ca840454a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@ pkgname=nginx-mainline-waf
_pkgname=nginx
provides=('nginx')
conflicts=('nginx')
-pkgver=1.9.2
+pkgver=1.9.10
pkgrel=1
-pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, mainline, with ngx_pagespeed, Naxsi, GeoIP (GeoIP Legacy) and YubiKey Auth Support builtin, with Thread Pools.'
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, mainline, with Naxsi, Certificate Transparency, GeoIP (GeoIP Legacy) mYubiKey Auth Support builtin and with Thread Pools.'
arch=('i686' 'x86_64')
url='http://nginx.org'
license=('custom')
@@ -27,17 +27,17 @@ backup=('etc/nginx/fastcgi.conf'
'etc/logrotate.d/nginx')
install=nginx.install
source=($url/download/nginx-$pkgver.tar.gz
- https://github.com/pagespeed/ngx_pagespeed/archive/release-$_psver.zip
- https://dl.google.com/dl/page-speed/psol/$_psolver.tar.gz
+ #https://github.com/pagespeed/ngx_pagespeed/archive/release-$_psver.zip
+ #https://dl.google.com/dl/page-speed/psol/$_psolver.tar.gz
git+https://github.com/nbs-system/naxsi.git
git+https://github.com/sanderv32/ngx_http_auth_yubikey_module.git
- git+https://github.com/aperezdc/ngx-fancyindex.git
+ #git+https://github.com/aperezdc/ngx-fancyindex.git
git+https://github.com/openresty/headers-more-nginx-module.git
+ git+https://github.com/grahamedgecombe/nginx-ct.git
service
logrotate)
build() {
- ln -sf "$srcdir"/psol "$srcdir"/ngx_pagespeed-release*
cd "$srcdir"/$_pkgname-$pkgver
./configure \
--prefix=/etc/nginx \
@@ -63,7 +63,7 @@ build() {
--with-http_gunzip_module \
--with-http_gzip_static_module \
--with-http_realip_module \
- --with-http_spdy_module \
+ --with-http_v2_module \
--with-http_ssl_module \
--with-http_stub_status_module \
--with-http_addition_module \
@@ -75,11 +75,10 @@ build() {
--with-http_geoip_module \
--with-stream \
--with-threads \
- --add-module=../ngx_pagespeed-release-$_psver \
- --add-module=../naxsi/naxsi_src \
--add-module=../ngx_http_auth_yubikey_module \
- --add-module=../ngx-fancyindex \
- --add-module=../headers-more-nginx-module
+ --add-module=../naxsi/naxsi_src \
+ --add-module=../headers-more-nginx-module \
+ --add-module=../nginx-ct
make
}
@@ -108,34 +107,23 @@ package() {
install -Dm644 ../service "$pkgdir"/usr/lib/systemd/system/nginx.service
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$provides/LICENSE
+ for i in ftdetect indent syntax; do
+ install -Dm644 contrib/vim/${i}/nginx.vim "${pkgdir}/usr/share/vim/vimfiles/${i}/nginx.vim"
+ done
+
rmdir "$pkgdir"/run
}
# vim:set ts=2 sw=2 et:
-md5sums=('572a0f217f845d3592b5ca779066d1c3'
- '2b3fe1f14b519c99b6412dafc5e8cb2e'
- '9f4d11cabbe5cd0c6945a4a89c82bff0'
- 'SKIP'
+md5sums=('50fdfa08e93ead7a111cba5a5f5735af'
'SKIP'
'SKIP'
'SKIP'
'ce9a06bcaf66ec4a3c4eb59b636e0dfd'
'3441ce77cdd1aab6f0ab7e212698a8a7')
-sha1sums=('814855ab98d6b0900207a6e5307252b130af61a2'
- '84605b331b4e961c19de93f16e6d7ea75836d48a'
- 'd0cda2462d52783ff22fefd86ff80b5945de7583'
- 'SKIP'
+sha1sums=('8262504469b86b967cdeb0821607a94ce863dfb4'
'SKIP'
'SKIP'
'SKIP'
'df6dd84b41f5127fec39216d578cfbbe1815699f'
'e43ccb1e8eb90bea64cb3cd0967a2df891473834')
-sha256sums=('80b6425be14a005c8cb15115f3c775f4bc06bf798aa1affaee84ed9cf641ed78'
- 'b84cb83dd591a1350d676a18b8b409757619485f38bec237613b223420b0cc62'
- 'f4d6f1788751aeb3c59931f7923b7eb2dff97743abf0bc6ae74dd5fd001207fa'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '05fdc0c0483410944b988d7f4beabb00bec4a44a41bd13ebc9b78585da7d3f9b'
- '272907d3213d69dac3bd6024d6d150caa23cb67d4f121e4171f34ba5581f9e98')