summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoman Voropaev2017-12-31 18:30:57 +0300
committerRoman Voropaev2017-12-31 18:36:33 +0300
commitb834742b9d07098715f2782b0180a45db1e4a109 (patch)
tree1a594fdc67ed024915c7767f6be2157fbd999669 /PKGBUILD
downloadaur-b834742b9d07098715f2782b0180a45db1e4a109.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c729f8cddf29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Roman Voropaev <voropaev.roma@gmail.com>
+
+pkgbase=nginx-unit
+pkgname=('nginx-unit-python' 'nginx-unit-php')
+_shortname=unit
+pkgver=0.3
+pkgrel=1
+pkgdesc="Dynamic web application server, designed to run applications in multiple languages."
+arch=('i686' 'x86_64')
+url="http://unit.nginx.org/"
+license=('Apache-2.0')
+optdepends=('python' 'php-embed')
+source=(http://hg.nginx.org/$_shortname/archive/$pkgver.tar.gz)
+md5sums=(62ac119c9e345e0b447356b543111b33)
+
+build() {
+ cd $srcdir/$_shortname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package_nginx-unit-python() {
+ cd $srcdir/$_shortname-$pkgver
+ ./configure python
+ make python
+ make DESTDIR=$pkgdir install || return 1
+}
+
+package_nginx-unit-php() {
+ cd $srcdir/$_shortname-$pkgver
+ ./configure php
+ make php
+ make DESTDIR=$pkgdir install || return 1
+}