summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDiab Neiroukh2020-11-04 17:17:48 +0000
committerDiab Neiroukh2020-11-04 17:17:48 +0000
commit9a953ce6d86340c3e4bfbe30d182cf2ded79edfb (patch)
tree7980a216d3c764c9a86793662b57766cdf25c4df /PKGBUILD
parent483c7eac7d48659fe16b84213e5c75d652601eb2 (diff)
downloadaur-9a953ce6d86340c3e4bfbe30d182cf2ded79edfb.tar.gz
👌 IMPROVE: Switch to mimalloc for memory allocation
mimalloc performs better than TCMalloc for all but Redis tests, so it's good for us here. Signed-off-by: Diab Neiroukh <lazerl0rd@thezest.dev>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3032d2f7094..e61167d28083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@
pkgbase=nginx-zest-git
pkgname=(nginx-zest-git nginx-zest-src-git)
-pkgver=1.19.4.r0.gb3f311dd8
-pkgrel=7
+pkgver=1.19.4.r0.g27ce47d2b
+pkgrel=8
epoch=3
pkgdesc='NGINX with beefed up security and performance'
arch=(x86_64)
url='https://github.com/ZestProjects/nginx'
license=(custom)
-depends=(pcre openssl geoip mailcap libxcrypt brotli gperftools liburing zstd)
+depends=(pcre openssl geoip mailcap libxcrypt brotli mimalloc liburing zstd)
makedepends=(mercurial git 'rust>=1.39')
checkdepends=(perl perl-gd perl-io-socket-ssl perl-fcgi perl-cache-memcached
memcached ffmpeg inetutils)
@@ -111,9 +111,7 @@ build() {
export CFLAGS="${CFLAGS//-flto=thinlto/}" # thinlto also breaks quiche
export CXXFLAGS="${CXXFLAGS//-fltothinlto/}" # thinlto also breaks quiche
- export CFLAGS="$CFLAGS -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free" # recommended for tcmalloc
- export CXXFLAGS="$CXXFLAGS -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free" # recommended for tcmalloc
- export LDFLAGS="$LDFLAGS -ltcmalloc" # needed for tcmalloc
+ export LDFLAGS="$LDFLAGS -lmimalloc" # use mimalloc as the memory allocator
cd nginx