summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122016-09-21 08:53:47 +0200
committerwillemw122016-09-21 08:53:47 +0200
commite71e9a88fbb67f6e6ddd315d9b0b20678d6b3b4a (patch)
tree2ab26a393742b92ebe49a0fda893bca8df3482c0 /PKGBUILD
parenta47f1d64c4000d45dc609fc9cbaa385d0fe0b3fe (diff)
downloadaur-e71e9a88fbb67f6e6ddd315d9b0b20678d6b3b4a.tar.gz
Update build steps. Add cmake to makedepends. Remove "ignore warning" (misleading-indentation).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4995c9b0de02..a05d028ca0ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=ngp
pkgname=$_pkgname-git
-pkgver=1.3.r61.g80dd78b
+pkgver=1.3.r98.g25e0fe5
pkgrel=1
pkgdesc="Ncurses grep tool"
arch=('i686' 'x86_64')
url="https://github.com/jonathanklee/ngp"
license=('GPL')
depends=('ncurses')
-makedepends=('git' 'libconfig')
+makedepends=('cmake' 'git' 'libconfig')
provides=($_pkgname)
conflicts=($_pkgname)
source=($pkgname::git://github.com/jonathanklee/ngp.git)
@@ -22,12 +22,7 @@ pkgver() {
build() {
cd $pkgname
-
- # Ignore warning
- CFLAGS="$CFLAGS -Wno-error=misleading-indentation"
-
- ./autogen.sh
- ./configure --prefix=/usr
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}