summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantinos Sideris2018-06-17 20:09:01 +0300
committerKonstantinos Sideris2018-06-17 20:09:01 +0300
commita6bff6cde87acbf4217484136ca4f3e20c122343 (patch)
tree1f38c35b8125b3b45e4041d9b5fdbf24086581a1 /PKGBUILD
parentb0d3488973ee6659faab123834a69ab4c5d79592 (diff)
downloadaur-a6bff6cde87acbf4217484136ca4f3e20c122343.tar.gz
Update with the new dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 151be572786e..677f1cb19a29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Konstantinos Sideris <siderisk at auth dot gr>
pkgname=nheko-git
-pkgver=0.4.0.r571.e032f293
+pkgver=0.4.3.r678.87042659
pkgrel=1
pkgdesc="Desktop client for the Matrix protocol"
arch=("i686" "x86_64")
@@ -9,7 +9,7 @@ arch=("i686" "x86_64")
url="https://github.com/mujx/nheko"
license=("GPL3")
-depends=("qt5-base" "lmdb" "qt5-multimedia" "qt5-svg")
+depends=("qt5-base" "lmdb" "qt5-multimedia" "qt5-svg" "boost" "libsodium" "openssl")
makedepends=("git" "cmake" "gcc" "fontconfig" "qt5-tools")
provides=("nheko")
@@ -24,11 +24,14 @@ prepare() {
pkgver() {
cd "$pkgname"
- printf "0.4.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "0.4.3.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "$pkgname"
+ cmake -Hdeps -B.deps -DUSE_BUNDLED_BOOST=OFF
+ cmake --build .deps
+
cmake -H. -Bbuild -DCMAKE_BUILD_TYPE=Release
cmake --build build
}