summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStuart Mumford2022-04-20 17:48:21 +0100
committerStuart Mumford2022-04-20 17:56:25 +0100
commit4364d5be36c5293e73dae7cb913731e0eba6eeb1 (patch)
tree247d3575017435f2fcf1ddf10af2b44118ef3b66 /PKGBUILD
downloadaur-4364d5be36c5293e73dae7cb913731e0eba6eeb1.tar.gz
Initial implementation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f4936e76cae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stuart Mumford <stuart at cadair dot com>
+
+pkgname=nheko-krunner-git
+pkgver=0.1.0.r0.gd5367d0
+pkgrel=1
+pkgdesc="A KRunner plugin to list joined rooms and possibly other things from nheko."
+arch=("i686" "x86_64" "aarch64")
+
+url="https://github.com/LorenDB/nheko-krunner/"
+license=("GPL3")
+
+depends=("qt5-base" "krunner")
+makedepends=("git" "cmake" "gcc" "fontconfig" "qt5-tools")
+provides=("nheko-krunner=${pkgver}")
+
+source=("$pkgname::git+https://github.com/LorenDB/nheko-krunner.git#branch=master")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cmake -DKDE_INSTALL_PLUGINDIR=`kf5-config --qt-plugins` .
+}
+
+package() {
+ cd "$pkgname"
+ DESTDIR="$pkgdir" make install
+}