summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-11-29 10:42:11 -0700
committerMark Wagie2022-11-29 10:42:11 -0700
commit1154b908b219dc9c3f29d97c5fb4179526bc6dc1 (patch)
tree72d7c3a4f66683a1bf7b277cf058ab2b13bdc768 /PKGBUILD
parent26c8ef258f10d972c24e84e0192b6fc90befb9db (diff)
downloadaur-1154b908b219dc9c3f29d97c5fb4179526bc6dc1.tar.gz
Gtk 4 now default
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 659674c692ba..de43c34cb49d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,25 @@
# Contributor: x-demon
pkgname=nicotine-plus-git
_appdata_id=org.nicotine_plus.Nicotine
-pkgver=3.3.0.dev3.r8228.fc511e27a
+pkgver=3.3.0.dev4.r8347.7b9969c63
pkgrel=1
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
url="https://nicotine-plus.org"
license=('GPL3')
-depends=('python-gobject' 'gtk3')
+depends=('python-gobject')
makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-optdepends=('gspell: for spell checking in chat'
- 'gtk4: test the GTK4 version'
+optdepends=('gspell: for spell checking in chat (Gtk 3 only)'
+ 'gtk4: default Gtk version'
+ 'gtk3: fallback if Gtk 4 is not installed'
'libadwaita: test the Libadwaita version')
checkdepends=('appstream-glib' 'desktop-file-utils' 'python-pytest-xvfb')
provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git'
- "${_appdata_id}-gtk4.desktop"
"${_appdata_id}-libadwaita.desktop")
sha256sums=('SKIP'
- 'ed5fe4e991655fa28736960b9fabc88541d3b43a2614dcaf6aad925ad86e1f14'
- '947a92b445a4c3becbf05f5f11f3ddcc7ccca95078ea1cbc22bfa5f409dbe9c8')
+ '076ecb7184bc435f9849b2669233819cca9d20e4d98d3541c04f1ee73bc0bcfc')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -57,6 +56,6 @@ package() {
cd "$srcdir/${pkgname%-git}"
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 "$srcdir/${_appdata_id}"{-gtk4,-libadwaita}.desktop -t \
+ install -Dm644 "$srcdir/${_appdata_id}-libadwaita.desktop" -t \
"$pkgdir/usr/share/applications/"
}