summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-05-26 14:33:53 -0600
committerMark Wagie2020-05-26 14:33:53 -0600
commit26c1e9df0c34598b7b7c50cc54039f275f8c8e7a (patch)
tree4a53dc95c2f5c54e83baceb586a03bdd225ca963 /PKGBUILD
parenta3f49ad5449d14f2e9d6031c7ce472a56fd5dc1a (diff)
downloadaur-26c1e9df0c34598b7b7c50cc54039f275f8c8e7a.tar.gz
generate pkgver from debian changelog
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f67bb03b022f..afd2ca2afbed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-pkgver=1.4.1.r293.gfcfcd66d
+pkgver=1.4.3.2.r2403.5b28af9e
pkgrel=1
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
@@ -25,7 +25,8 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "%s.r%s.%s" "$(head -n 1 debian/changelog | cut -d'(' -f 2 | cut -d')' -f 1 | \
+ sed 's/-/./')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {