summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2015-09-10 22:18:09 +0200
committeranthraxx2015-09-10 22:18:09 +0200
commitd1558a86136277834d81fe9660562de8a53e3ac8 (patch)
tree1c7fbe04940d4406dd5264130a33318670a94807 /PKGBUILD
parent1e279fdd9d6a6700c81e1b3bba406f17e035ca12 (diff)
downloadaur-d1558a86136277834d81fe9660562de8a53e3ac8.tar.gz
upgpkg: nikto-git 2.1.6.601.7ac0457-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb829d942c95..0f58b5fe9e28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgname=nikto-git
-pkgver=2.1.6
+_gitname=nikto
+pkgver=2.1.6.601.7ac0457
pkgrel=1
pkgdesc='A web server scanner which performs comprehensive tests against web servers for multiple items'
url='https://github.com/sullo/nikto'
@@ -10,22 +11,35 @@ license=('GPL')
depends=('sh' 'openssl' 'perl-net-ssleay' 'perl-json')
makedepends=('git')
backup=('etc/nikto.conf')
-install=nikto.install
-source=(${pkgname}::git+https://github.com/sullo/${pkgname}
+provides=('nikto')
+conflicts=('nikto')
+source=(${pkgname}::git+https://github.com/sullo/${_gitname}
nikto.sh)
-sha512sums=('13632018ef6862de7dc53c674d7266fcfb7e164bcf3070327c103cbf8737720ffb710ccc8949acc920a6e0a85da1bb7575d073ee245bc2ba3a8a292ad1695e69'
+sha512sums=('SKIP'
'75b9be1f1cacbca09a5e72f8125aadc24938a3ac36b2337bf68916231af52e2af846a0dedb36782f45716d2c6d590a3606cb5879339528e7a744f1d2d880120d')
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ find . -type f ! -name nikto.pl -exec chmod 644 {} +
+}
+
package() {
cd ${pkgname}
+
install -d "${pkgdir}/usr/share/nikto"
cp -a program/* "${pkgdir}/usr/share/nikto"
- #find $pkgdir/usr/share/nikto -type f -exec chmod 644 {} +
+
install -Dm 755 "${srcdir}/nikto.sh" "${pkgdir}/usr/bin/nikto"
+ install -Dm 644 program/nikto.conf "${pkgdir}/etc/nikto.conf"
install -Dm 644 documentation/nikto.1 "${pkgdir}/usr/share/man/man1/nikto.1"
install -Dm 644 program/docs/nikto_manual.html "${pkgdir}/usr/share/doc/${pkgname}/manual.html"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
- ln -s /usr/share/nikto/nikto.conf "${pkgdir}/etc/nikto.conf"
}
# vim: ts=2 sw=2 et: