summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-01-11 21:43:43 +0300
committerCaleb Maclennan2023-01-11 21:43:43 +0300
commit1cac2f6b671de02c9a4b8e329bdf4882cc263f53 (patch)
tree9615ce5047832ab902426e88fda19ce9e642f7ef /PKGBUILD
parent53b616cfb5497e30132600ee8b1b094f1a9a6b8b (diff)
downloadaur-1cac2f6b671de02c9a4b8e329bdf4882cc263f53.tar.gz
upgpkg: nimf 1:1.3.1-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fbf87d71b2b..39b147cbcf4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,9 @@
# Contributor: Bumsik Kim <k.bumsik@gmail.com>
# Contributor: Hodong Kim <https://gitlab.com/hodong>
-# Note upstream seems to have several build system experiments going on. The
-# AUR package nimf-git which upstream endorses uses a branch older
-# than the current release with meson in it. I've left some meson stuff in this
-# PKGBUILD in case that ever hits a tagged release.
-
pkgname=nimf
-pkgver=1.3.0
-pkgrel=2
+pkgver=1.3.1
+pkgrel=1
epoch=1
pkgdesc='a lightweight, fast and extensible input method framework'
arch=(x86_64)
@@ -27,30 +22,29 @@ makedepends=(anthy
gtk-doc
gtk2
intltool
- libhangul
+ libayatana-appindicator
+ libhangul-git
librime
m17n-db
m17n-lib
- # meson
librsvg)
-optdepends=(#'brise: Rime schema repository'
+optdepends=('brise: Rime schema repository'
'noto-fonts-cjk: Google Noto CJK fonts')
_archive="$pkgname-$pkgver"
-source=("$pkgname-$pkgver.tar.bz2::$url/releases/download/$pkgver/$pkgname-master.tar.bz2")
-sha256sums=('543ccaa963a8366d68162887fadf61dc36425a99aad6d3bb075e8b0039ef9ed2')
+source=("$url/archive/$pkgver/$_archive.tar.gz")
+sha256sums=('330d382fdc0799a98e5ee0ba7330fd55b0d10346b4ffd19901d8d86de817d4c7')
-build() {
+prepare() {
cd "$_archive"
./autogen.sh
+}
+
+build() {
+ cd "$_archive"
./configure --prefix /usr
- # arch-meson \
- # -D with_nimf_qt4=false
- # "$_archive" build \
- # ninja -C build
}
package() {
cd "$_archive"
make DESTDIR="$pkgdir/" install
- # DESTDIR="$pkgdir/" ninja -C build install
}