summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHodong Kim2018-07-22 20:34:25 +0900
committerHodong Kim2018-07-22 20:34:25 +0900
commit3b291aba7a42b9d6342b4c805dc9a3557088d933 (patch)
treed4b1ee37d789b7544cdd446b3c58ba569f2f1487 /PKGBUILD
parent52f0a03df3c5e108017342838f17020e4ba23a23 (diff)
downloadaur-3b291aba7a42b9d6342b4c805dc9a3557088d933.tar.gz
revert to 2017-06-10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 24 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e30484da5206..3a8ab720e7ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,40 @@
-# Maintainer: Hodong Kim <cogniti@gmail.com>
+# Maintainer: Youngbin Han <sukso96100@gmail.com>
+# Submitter: Youngbin Han <sukso96100@gmail.com>
+# Contributor: Changjoo Lee <icj7061@gmail.com>
+# Contributor: ywen407 <ywen407@naver.com>
pkgname=nimf-git
-pkgver=master
+_pkgname=nimf
+pkgver=2017.01.28.aa61961
pkgrel=1
-pkgdesc="Nimf is an input method framework."
+pkgdesc="Nimf is an input method framework"
arch=('any')
-url="https://gitlab.com/nimf-i18n/nimf"
-license=('LGPL3')
-makedepends=('binutils' 'autoconf' 'automake' 'gcc' 'make' 'glib2' 'intltool'
- 'gtk3' 'gtk2' 'qt4' 'qt5-base' 'libappindicator-gtk3' 'librsvg'
- 'noto-fonts-cjk' 'libhangul' 'anthy' 'libchewing' 'librime'
- 'libxkbcommon' 'wayland' 'audit')
-depends=('glib2' 'gtk3' 'gtk2' 'qt4' 'qt5-base' 'libappindicator-gtk3'
- 'libhangul' 'anthy' 'libchewing' 'librime' 'libxkbcommon' 'wayland'
- 'audit')
-optdepends=('brise: Rime schema repository'
- 'noto-fonts-cjk: Google Noto CJK fonts'
- 'xorg-setxkbmap: Set the keyboard using the X Keyboard Extension')
-source=("https://gitlab.com/nimf-i18n/nimf/-/archive/master/nimf-master.tar.bz2")
+url="https://cogniti.github.io/${_pkgname}"
+license=('GNU LGPL v3')
+depends=('gtk2' 'gtk3' 'qt4' 'qt5-base' 'libxkbcommon' 'glib2'
+'libappindicator-gtk3' 'libhangul' 'sunpinyin' 'sunpinyin-data' 'anthy' 'libchewing' 'librime' 'brise')
+makedepends=('gtk2' 'gtk3' 'qt4' 'qt5-base' 'intltool'
+'gobject-introspection' 'glib2' 'libappindicator-gtk3' 'git' 'librsvg'
+'noto-fonts-cjk' 'libhangul' 'sunpinyin' 'sunpinyin-data' 'anthy'
+'libchewing' 'librime' 'brise' 'audit')
+conflicts=("nimf")
+source=("${_pkgname}"::"git+https://github.com/cogniti/${_pkgname}.git")
md5sums=('SKIP')
+options=(!buildflags)
+install=$pkgname.install
+groups=('nimf')
pkgver() {
- cd "$srcdir/nimf-master"
- grep AC_INIT configure.ac | grep -Po '\d{4}.\d{2}.\d{2}'
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git tag | sort -V | tail -1).$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/nimf-master"
+ cd "${srcdir}/${_pkgname}"
./autogen.sh --prefix=/usr
make
}
-
package() {
- cd "$srcdir/nimf-master"
+ cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}/" install
}