summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author7k5x2021-08-26 16:33:07 +0900
committer7k5x2021-08-26 16:33:07 +0900
commitff15b10fedb9de18e8a43a8c36dc0fe5d4182ef0 (patch)
tree90ff4933d29c5f0fc7686e6f28428fcf655bee8d /PKGBUILD
parent88e5f3b22c11e48d65f6434ee9de9946dba5272e (diff)
downloadaur-ff15b10fedb9de18e8a43a8c36dc0fe5d4182ef0.tar.gz
Update functions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b42f6d0a7c6..6a5ab3a62407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,9 @@ pkgdesc="Nimf is a lightweight, fast and extensible input method framework."
arch=('any')
url="https://github.com/hamonikr/nimf"
license=('LGPL3')
-depends=(gtk3
+depends=(
+ 'glibc'
+ 'gtk3'
'glib2'
'libhangul-git'
'libappindicator-gtk3'
@@ -43,7 +45,21 @@ pkgver() {
rm -rf ../../nimf
}
+post_install() {
+ echo "Compiling schemas..."
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ echo "Running ldconfig..."
+ ldconfig
+ echo "Updating GTK icon cache..."
+ gtk-update-icon-cache
+ echo "Updating immodules cache..."
+ gtk-query-immodules-3.0 --update-cache
+ gtk-query-immodules-2.0 --update-cache
+}
+post_upgrade() {
+ post_install $1
+}
build() {
cd "$srcdir/nimf"
./autogen.sh --prefix=/usr