summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2024-01-23 10:44:15 +0300
committerCaleb Maclennan2024-01-23 10:44:15 +0300
commit91e6bb3b893e1bbd9175089fba3c21171872c400 (patch)
tree4fc58b58281e8fbade3ef5bdf23adba1e510faac /PKGBUILD
parent3531bf2e8c077c28c000674f2bf16eadcc748b17 (diff)
downloadaur-91e6bb3b893e1bbd9175089fba3c21171872c400.tar.gz
upgpkg: nixpacks 1.21.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c211476ddc6..b81fc4534e1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
BUILDENV+=(!check)
pkgname=nixpacks
-pkgver=1.20.0
+pkgver=1.21.0
pkgrel=1
pkgdesc='App source + Nix packages + Docker = Image'
arch=(x86_64)
@@ -18,23 +18,26 @@ optdepends=('go: support go projects'
options=('!lto')
_archive="$pkgname-$pkgver"
source=("$_url/archive/v$pkgver/$_archive.tar.gz")
-sha256sums=('0f2cdd80879dc97d07ffb36a84aaf56f524b1466f88276afd210cdcc9f07e462')
+sha256sums=('559cfb9c73da174ea4999d5ac93cb19408244db15b4fc773e31a10d24489d772')
prepare() {
cd "$_archive"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}
-build() {
+_srcenv() {
cd "$_archive"
- local RUSTUP_TOOLCHAIN=stable
- local CARGO_TARGET_DIR=target
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+}
+
+build() {
+ _srcenv
cargo build --frozen --release --all-features
}
check() {
- cd "$_archive"
- local RUSTUP_TOOLCHAIN=stable
+ _srcenv
cargo test --frozen --all-features -- \
--skip "test_get_default_cache_key" \
--skip "docker_run_tests"