summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Heidelberg2011-10-30 13:13:00 +0100
committerMarkus Heidelberg2015-06-26 10:57:16 +0200
commit212e666d1eb143e171bf1044b3bd4b91320558cf (patch)
tree2105e5710260d1546d56a3720f3f74f67168674a /PKGBUILD
parent029e128568edff26256db5aa6fcfeb9294f60f6c (diff)
downloadaur-212e666d1eb143e171bf1044b3bd4b91320558cf.tar.gz
njam 1.25-7: fix compile errors
Compile errors fixed with a patch from Gentoo. error: cannot call constructor ‘LogFile::LogFile’ directly error: for a function-style cast, remove the redundant ‘::LogFile’ ** Manually imported from AUR 3 **
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4158fb7a8e1..89ffaeb64c14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Contributor: Stefano "GeniE" Faraone <xgotux@gmail.com>
+# Maintainer: Markus Heidelberg <markus dot heidelberg at web dot de>
pkgname=njam
pkgver=1.25
-pkgrel=6
+pkgrel=7
pkgdesc="Full-featured cross-platform pacman-like game"
url="http://njam.sourceforge.net/"
license=('GPL')
arch=('i686' 'x86_64')
depends=('sdl_image' 'sdl_mixer' 'sdl_net')
-source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz njam.desktop)
-md5sums=('b49f65a0c5df83de85df4f985337e2eb' 'a2e8f7e419de1b864c31342003ebcd4d')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz njam.desktop njam-1.25-gcc45-archlinux.patch)
+md5sums=('b49f65a0c5df83de85df4f985337e2eb' 'a2e8f7e419de1b864c31342003ebcd4d' '0add7095857fe517d35abdbd79e25259')
build() {
cd ${srcdir}/${pkgname}-${pkgver}-src
+ patch -p0 < ${srcdir}/njam-1.25-gcc45-archlinux.patch
./configure --prefix=/usr
make clean || return 1 # Delete the binary files which are distributed in the tar file
make || return 1