summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Bus2018-04-03 00:49:41 +0700
committerAlexander Bus2018-04-03 00:49:41 +0700
commitd2f24d382decc805294996d83ee7156ce675a367 (patch)
treeaf4c98da8c99d61c38675163a220738d67c5d3f5 /PKGBUILD
parentbf18a049b778e55b7cb37812addcd129f5603693 (diff)
downloadaur-d2f24d382decc805294996d83ee7156ce675a367.tar.gz
Replaced the rm hack with source renaming
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1abbeb7a8afa..26798bccc1e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url='https://github.com/nlohmann/json'
license=('MIT')
provides=('nlohmann-json')
conflicts=('nlohmann-json' 'nlohmann-json-git')
-source=("https://github.com/nlohmann/json/releases/download/v${pkgver}/include.zip"
+source=("include-${pkgver}.zip::https://github.com/nlohmann/json/releases/download/v${pkgver}/include.zip"
"https://raw.githubusercontent.com/nlohmann/json/v${pkgver}/LICENSE.MIT")
sha256sums=('495362ee1b9d03d9526ba9ccf1b4a9c37691abe3a642ddbced13e5778c16660c'
'7b875bb7a4e28abb7956ea821b4b7d88ff6a2a4fabf261c3993730a365ec56dd')
@@ -18,6 +18,4 @@ package() {
cd "${srcdir}"
install -Dm644 LICENSE.MIT "${pkgdir}/usr/share/licenses/nlohmann-json/LICENSE.MIT"
cp -R include "${pkgdir}/usr"
- # include.zip has to be deleted to ensure it gets re-downloaded whenever the package updates
- rm ../include.zip
}