summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Bus2019-10-12 13:26:18 +0700
committerAlexander Bus2019-10-12 13:26:18 +0700
commitf0ffcad5a70519c67056756c12ef83f1167cdfdf (patch)
tree5961116ddff1e779c1c7d2d379d7a9cd09f484fc /PKGBUILD
parent21673fba2170fef269ca1b9810cad722e20b2757 (diff)
downloadaur-f0ffcad5a70519c67056756c12ef83f1167cdfdf.tar.gz
Add files for CMake
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17d1430d3e02..42cbb58c0af4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nlohmann-json-bin
pkgver=3.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Header-only JSON library for Modern C++ (quick installation without testing)'
arch=('any')
url='https://github.com/nlohmann/json'
@@ -10,12 +10,18 @@ license=('MIT')
provides=('nlohmann-json')
conflicts=('nlohmann-json' 'nlohmann-json-git')
source=("include-${pkgver}.zip::https://github.com/nlohmann/json/releases/download/v${pkgver}/include.zip"
- "https://raw.githubusercontent.com/nlohmann/json/v${pkgver}/LICENSE.MIT")
+ "https://raw.githubusercontent.com/nlohmann/json/v${pkgver}/LICENSE.MIT"
+ "nlohmann_json-config.cmake"
+ "nlohmann_json-config-version.cmake")
sha256sums=('541c34438fd54182e9cdc68dd20c898d766713ad6d901fb2c6e28ff1f1e7c10d'
+ 'SKIP'
+ 'SKIP'
'SKIP')
package() {
cd "${srcdir}"
install -Dm644 LICENSE.MIT "${pkgdir}/usr/share/licenses/nlohmann-json/LICENSE.MIT"
+ install -Dm644 nlohmann_json-config.cmake "${pkgdir}/usr/lib/cmake/nlohmann_json/nlohmann_json-config.cmake"
+ install -Dm644 nlohmann_json-config-version.cmake "${pkgdir}/usr/lib/cmake/nlohmann_json/nlohmann_json-config-version.cmake"
cp -R include "${pkgdir}/usr"
}