summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesin2018-01-03 11:25:36 -0500
committerJesin2018-01-03 11:25:36 -0500
commit790fb8b1cca2dea729319e586aa8f979c349925b (patch)
treebee5a7c75f868a2af0cf0d77b43bf8fa7423ffd6 /PKGBUILD
parent80d997c3e53c97f972926e971a733ae20f1e3e7a (diff)
downloadaur-790fb8b1cca2dea729319e586aa8f979c349925b.tar.gz
Update to 3.0.1; add version to provides
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 852d9fc00930..e3b9ca1f0adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,13 @@
# Contributor: Eduardo Sánchez Muñoz
pkgname=nlohmann-json-git
_name="${pkgname%-git}"
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc='Header-only JSON library for Modern C++'
url='https://github.com/nlohmann/json'
license=(MIT)
arch=(x86_64)
makedepends=(cmake git)
-provides=("$_name")
-conflicts=("$_name")
source=("git+$url")
sha256sums=(SKIP)
@@ -34,6 +32,8 @@ check() {
}
package() {
+ provides=("$_name=${pkgver%%+*}")
+ conflicts=("$_name")
cd build
make "DESTDIR=$pkgdir" install
install -Dm644 "-t$pkgdir/usr/share/licenses/$_name" ../json/LICENSE.MIT