summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesin2018-01-04 15:15:12 -0500
committerJesin2018-01-04 15:15:12 -0500
commit9c63c5674d3ec85dc6318f60c55dd429e9e065f0 (patch)
treee751debb2ae9b19a49110eefb73a61aadfd223fd /PKGBUILD
parent790fb8b1cca2dea729319e586aa8f979c349925b (diff)
downloadaur-9c63c5674d3ec85dc6318f60c55dd429e9e065f0.tar.gz
move provides and conflicts to toplevel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3b9ca1f0adf..3a87f4e746bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,8 @@ url='https://github.com/nlohmann/json'
license=(MIT)
arch=(x86_64)
makedepends=(cmake git)
+provides=("$_name=${pkgver%%+*}")
+conflicts=("$_name")
source=("git+$url")
sha256sums=(SKIP)
@@ -32,8 +34,6 @@ check() {
}
package() {
- provides=("$_name=${pkgver%%+*}")
- conflicts=("$_name")
cd build
make "DESTDIR=$pkgdir" install
install -Dm644 "-t$pkgdir/usr/share/licenses/$_name" ../json/LICENSE.MIT