summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-06-26 14:28:40 +0300
committerCaleb Maclennan2023-06-26 14:28:40 +0300
commit1f85492c0fca6e0ce9066943ae7eb7daf2d2b20a (patch)
treeb2f0cbe6ba27dd236158fd5d4c1c9f52fb3745a6 /PKGBUILD
parent4d28c97fdaa0490aa290c5294422c108aa241028 (diff)
downloadaur-1f85492c0fca6e0ce9066943ae7eb7daf2d2b20a.tar.gz
upgpkg: node-prune 1.2.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88d5f45c57ba..989666a209d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
pkgname=node-prune
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Remove unnecessary files from node_modules'
-arch=('x86_64')
+arch=(x86_64)
url="https://github.com/tj/$pkgname"
license=(MIT)
makedepends=(go)
_archive="$pkgname-$pkgver"
-source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('9f1ad75fc637b4a77b7082ed090b99e5da860afffc096e4d2b90961b4a7caec3')
prepare() {
- # Patch because some AUR projects that use this actually _use_ the images (electron stuff)
cd "$_archive"
+ # Patch because some AUR projects dependent on this actually _use_ image assets (notably Electron stuff)
sed -i -e '/"images",/d' internal/prune/prune.go
}
@@ -32,7 +32,7 @@ build() {
package() {
cd "$_archive"
- install -Dm755 -t "$pkgdir/usr/bin/" "$pkgname"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" {History,Readme}.md
+ install -Dm0755 -t "$pkgdir/usr/bin/" "$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" {History,Readme}.md
}