summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjason2019-01-15 09:20:19 +1300
committerjason2019-01-15 09:20:19 +1300
commit45ab836259ab8e1cd7ae76314833085de41fba87 (patch)
treebe441e7815f24988be4897e4c856b9a5111d436b /PKGBUILD
downloadaur-45ab836259ab8e1cd7ae76314833085de41fba87.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c47e9edc4a08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: jasonwryan <jasonwryan@gmail.com>
+
+pkgname=nodejs-airfile-git
+_name=airfile
+pkgver=2019.01.13
+pkgrel=1
+pkgdesc="Transfer files from android to your local machine"
+arch=('any')
+url="https://github.com/noffle/${_name}"
+makedepends=('npm' 'git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+license=('ISC')
+source=("${_name}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ git log -1 --format="%cd" --date=short | sed 's/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ npm install -g --prefix "$pkgdir/usr" "${source[@]##*/}"
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$_name/LICENSE"
+}
+