summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Lubineau2015-09-15 15:29:16 +0200
committerAntoine Lubineau2015-09-15 15:29:16 +0200
commitf1d9125e4b6096c253dfe14f11a8994cbe01c825 (patch)
treef994ac819fd8695b1b76caccaf267bb81fe812e6 /PKGBUILD
downloadaur-f1d9125e4b6096c253dfe14f11a8994cbe01c825.tar.gz
0.9.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f304b50a1947
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
+
+_npmname=azure-cli
+_npmver=0.9.9
+pkgname=nodejs-${_npmname} # All lowercase
+pkgver=${_npmver}
+pkgrel=1
+pkgdesc="Windows Azure Cross Platform Command Line tool"
+arch=(any)
+url="https://github.com/Azure/azure-xplat-cli"
+license=('Apache')
+depends=('nodejs')
+source=("http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz")
+noextract=("$_npmname-$_npmver.tgz")
+options=(!strip)
+sha256sums=('585af418f18a84d0236f13c23f10a44ae2957d06e366ea34b293a0c9a7927866')
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: