summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMicha Alt2016-03-16 19:54:38 +0100
committerMicha Alt2016-03-16 19:54:38 +0100
commit3a93d9a3eecbd0efc232e8f4ef304c2c667ec69d (patch)
tree94cc07e583220c023117ac8fe86925fee8696036 /PKGBUILD
parent2ee4c5fd085d8b2965b63dfe513bc2d414a6fb5e (diff)
downloadaur-3a93d9a3eecbd0efc232e8f4ef304c2c667ec69d.tar.gz
upgpkg: nodejs-brunch 2.5.0-1
upstream release Brunch 2.5.0 (Mar 16, 2016) * Improved NPM support: * Added support for scoped npm packages, like @cycle/dom. * Brunch will now try to npm install if you try to require a package that is present in package.json but was not installed. * optionalDependencies are now correctly ignored when not present. * peerDepdenencides are treated as required ones. * Improperly-cased requires (like React instead of react) will now throw compile errors. * Fixed npm mail file resolving which was not working before in some cases (rx). * Support for file extensions: * Brunch will now register CommonJS modules using full names of the files, and create aliases without extensions to allow you to use both styles of requires. * Basically these cases are possible & different now: require('file.json') and require('file.js') * Parallel builds: Bringing up to 50% performance improvement with just one simple flag. * You can use the -j 2 / 4 flag with build / watch to parallelize CPU-bould tasks in your build. See docs/commands.md for more details. * React hot load support: * Bumped commonjs-require-definition to allow resetting modules, which can be used for live JS reloading with the updated auto-reload-brunch * Improved output for JavaScript files. * Allow to specify again conventions.vendor as an anymatch set.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28c62cdf5464..26cd2be3e568 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_npmname=brunch
pkgname=nodejs-$_npmname
-pkgver=2.4.2
+pkgver=2.5.0
pkgrel=1
pkgdesc="A lightweight approach to building HTML5 applications with emphasis on elegance and simplicity."
arch=('any')
@@ -15,7 +15,7 @@ optdepends=()
source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz
'LICENSE')
noextract=($_npmname-$pkgver.tgz)
-sha1sums=('93472188d6bc08ce9d6ecdbdf0cc73f5a584e9b1'
+sha1sums=('2e932ecb3fb11b1cf863f3dd38da2f9bf985ecb6'
'33743a055a6ce2165bde37eebca24f3c05ad9583')
package() {