summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago Almeida2018-11-15 12:54:09 -0200
committerThiago Almeida2018-11-15 12:54:09 -0200
commit93e4e3e6c22360d5dc0be070bf9615ca6dd26767 (patch)
tree81c1fa753989ed272a957f937a89691ce56fbf72 /PKGBUILD
downloadaur-93e4e3e6c22360d5dc0be070bf9615ca6dd26767.tar.gz
Initial commit for nodejs-commitlint pgk
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31c62fb4fe7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thiago Almeida <thiagoalmeidasa@gmail.com>
+_npmname=commitlint
+_npmver=7.2.1
+pkgname=nodejs-commitlint # All lowercase
+pkgver=7.2.1
+pkgrel=1
+pkgdesc="Lint your commit messages"
+arch=(any)
+url="https://github.com/marionebl/commitlint#readme"
+license=(MIT)
+depends=('nodejs' 'npm')
+optdepends=()
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(c1d50a26bf2324b60a0f67507b20dc0a74976a8c)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: