summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2017-05-02 13:33:39 +0300
committerChristoph Gysin2017-05-02 13:33:39 +0300
commite9f6a02565e050be9b6f13480ae50b37dac1085b (patch)
tree39232eaa6162b33ca24ebf7e5420d0daa4965008 /PKGBUILD
downloadaur-e9f6a02565e050be9b6f13480ae50b37dac1085b.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e450b214d1d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+_npmname=feathers-cli
+_npmver=2.0.5
+pkgname=nodejs-$_npmname
+pkgver=$_npmver
+pkgrel=1
+pkgdesc="The command line interface for Feathers applications"
+arch=(any)
+url="https://github.com/feathersjs/feathers-cli#readme"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=('164ace795ca4b17323c442ac22813ce6cdcc324b')
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: