summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Levy2019-06-16 15:56:10 -0400
committerBenjamin Levy2019-06-16 15:56:10 -0400
commit2a8fca58d71a20e62f21cd9ab25c33a8257843ab (patch)
tree8f003c8ee4c64b5080998b8fef2eaad68cf3d989 /PKGBUILD
downloadaur-nodejs-ffmpeg-concat.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cad36e0f8430
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=ffmpeg-concat
+_npmver=1.0.13
+pkgname=nodejs-ffmpeg-concat # All lowercase
+pkgver=1.0.13
+pkgrel=1
+pkgdesc="Concats a list of videos together using ffmpeg with sexy OpenGL transitions."
+arch=(any)
+url="https://github.com/transitive-bullshit/ffmpeg-concat"
+license=(MIT)
+depends=('nodejs' 'npm')
+optdepends=()
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(a8e3bfdbf7491e9dbf5496b1ee404146051c7079)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: