summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2016-07-13 06:45:10 -0400
committerMario Finelli2016-07-13 06:45:10 -0400
commit61c773b802278d8e4897803c95680f27f453f435 (patch)
tree1e339f47f4208dc9cea2878b8ff78395c173ccf5 /PKGBUILD
downloadaur-61c773b802278d8e4897803c95680f27f453f435.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d933ebd0872e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_npmname=foundation-cli
+pkgname=nodejs-$_npmname
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Command-line interface for the Foundation family of frameworks."
+arch=('any')
+url="http://foundation.zurb.com/"
+license=('MIT')
+depends=('nodejs' 'npm')
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha256sums=('eb14342835eca949729eefa1554a509ce9c70d8d035124d2470437b3c929be5a')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}