summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:39:19 -0300
committerBruno Galeotti2015-06-08 15:39:19 -0300
commit78328d9d2d5a075d9ea5d0a45034d8ae6d8e0b49 (patch)
treec47bb5a4dfcc0c9770c0d97ceeb9188c8cbb7ea5 /PKGBUILD
downloadaur-78328d9d2d5a075d9ea5d0a45034d8ae6d8e0b49.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28fe37395a45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Bruno Galeotti <bgaleotti at gmail dot com>
+_npmname=git-stats
+pkgname=nodejs-git-stats
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A GitHub-like contributions calendar, but locally, with all your git commits."
+arch=('any')
+url="https://github.com/IonicaBizau/git-stats"
+depends=('nodejs')
+license=('MIT')
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}
+sha256sums=('b6a59c5546c0f24c4b00bbb8d86a660bb9c162b8f040683760f0920c26435a22')
+# vim:set ts=2 sw=2 et: