summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Price2016-03-06 21:59:19 +0000
committerWill Price2016-03-06 21:59:19 +0000
commit33a80953260a4f2dea1ced70485b80d13ca6f5c3 (patch)
treef18d2a7f2cc505c7f1b6208f11a293c73d52cd4f /PKGBUILD
downloadaur-33a80953260a4f2dea1ced70485b80d13ca6f5c3.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdbd958a577a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=gitbook-cli
+_npmver=2.1.2
+pkgname=nodejs-gitbook-cli # All lowercase
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="CLI to generate books and documentation using gitbook"
+arch=(any)
+url="https://www.gitbook.com"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(6cf75e187435eb61513bb85dce85b319e3586a3a)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: