summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Vincent2017-05-15 11:24:59 +0100
committerTom Vincent2017-05-15 11:24:59 +0100
commit3b539f3105ad477cc5164d1b55381e63f5d3b26b (patch)
tree7d2ad84c5d48cc873c23899e5004791c028f5200 /PKGBUILD
downloadaur-3b539f3105ad477cc5164d1b55381e63f5d3b26b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19adeaa52a40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+_npmname=have-it
+pkgname=nodejs-$_npmname
+pkgver=1.11.1
+pkgrel=1
+pkgdesc="The fastest NPM install does nothing because you already have it"
+arch=(any)
+url="https://github.com/bahmutov/have-it"
+license=('MIT')
+depends=('npm')
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha256sums=('840a1585960dfc2d4a18b1fed437929cd18111075b23fcbfa00822a6279edae9')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
+ chmod -R go-w "$pkgdir"/usr
+}