summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-10 14:05:57 +0300
committerCaleb Maclennan2020-02-10 14:05:57 +0300
commita113e6462b2b5f592fe9e52306bdc901f757175e (patch)
tree204e2e9e9faf5ec657fd83c57568c673c7dcb673 /PKGBUILD
parent2f0a6428998c12d5aa7d509fd34935ae6760579a (diff)
downloadaur-a113e6462b2b5f592fe9e52306bdc901f757175e.tar.gz
Fix symlink permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1068444c4715..d49129070c5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_npmname=jshint
pkgname=nodejs-"$_npmname"
pkgver=2.11.0
-pkgrel=2
+pkgrel=3
pkgdesc='Static analysis tool for JavaScript'
arch=('any')
url='https://jshint.com/'
@@ -17,6 +17,7 @@ noextract=("${source[@]##*/}")
package() {
npm install -g --user root --cache "${srcdir}/npm-cache" --prefix "$pkgdir/usr" "${source[0]}"
- find "$pkgdir" -name package.json -execdir sed -i -e '/_where/d' {} \;
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+ find "${pkgdir}" -type f -name package.json -exec sed -i -e '/_where/d' {} \;
chown -R root:root $pkgdir
}