summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2018-02-28 11:31:09 +0300
committerCaleb Maclennan2018-02-28 11:31:25 +0300
commit06dbc2905a5041e2511acb4f91566f2186e17a54 (patch)
treed3adb8364b8eebfe707f2fa407fb498f670cbb72 /PKGBUILD
parentfaa1de28975e8490eb131fb9cabe7f9b84c5a43a (diff)
downloadaur-06dbc2905a5041e2511acb4f91566f2186e17a54.tar.gz
Upgrade to 1.6.3 and update packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a94a143effd..298e253a24c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Justin Dray <justin@dray.be>
# Contributor: Florent Peterschmitt
_npmname=jsonlint
-pkgname=nodejs-jsonlint # All lowercase
-pkgver=1.6.2
-pkgrel=2
-pkgdesc="Validate JSON"
+pkgname=nodejs-${_npmname}
+pkgver=1.6.3
+pkgrel=1
+pkgdesc='Validate JSON'
arch=(any)
-url="http://zaach.github.com/jsonlint/"
+url='http://zaach.github.com/jsonlint/'
license=('MIT')
depends=('nodejs'
'npm')
makedepends=('nodejs')
-source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+source=("http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
noextract=($_npmname-$pkgver.tgz)
-md5sums=('4849a84bcf4864bd61c552711979e8cd')
+sha256sums=('987f42f0754b7bc0c84967b81fc2b4db0ed2ebe2117ccc5a5faa59e462447723')
package() {
- cd $srcdir
- local _npmdir="$pkgdir/usr/lib/node_modules/"
- mkdir -p $_npmdir
- cd $_npmdir
- npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ npm install -g --prefix $pkgdir/usr $_npmname-$pkgver.tgz
+ rmdir $pkgdir/usr/etc
}