summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSuIông .N2015-08-31 20:06:49 +0800
committerSuIông .N2015-08-31 20:06:49 +0800
commit10a5e033ea6452983a584401f6e1c6fa40045ffa (patch)
tree2c20dc8fce95a5f062d289198a0234dcaaeec977 /PKGBUILD
downloadaur-10a5e033ea6452983a584401f6e1c6fa40045ffa.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec3b8f6a4fb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Boteium <echo Ym90ZWl1bUBnbWFpbC5jb20=|base64 -d>
+
+_npmname=node-forge
+pkgname=nodejs-node-forge
+pkgver=0.6.34
+pkgrel=1
+pkgdesc="JavaScript implementations of network transports, cryptography, ciphers, PKI, message digests, and various utilities"
+arch=(any)
+url="https://www.npmjs.com/package/node-forge"
+license=( "GPLv2" )
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+md5sums=('b651976fdf4f7672b22a358d271c8adc')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}
+
+# vim:set ts=2 sw=2 et: