summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2019-04-05 17:50:31 +0300
committerCaleb Maclennan2019-04-05 17:50:51 +0300
commitc3e4bbb0f2c86b87686556895c9ecf79f853313f (patch)
treeb61795e9d50bd1ae69262e55a9670bb117934791 /PKGBUILD
downloadaur-c3e4bbb0f2c86b87686556895c9ecf79f853313f.tar.gz
Initial add based on npm2PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6265d94e7c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_npmname=pandiff
+pkgname=nodejs-"$_npmname"
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Prose diffs for any document format supported by Pandoc'
+arch=('any')
+url="https://github.com/davidar/pandiff#readme"
+license=('MIT')
+depends=('nodejs' 'npm' 'pandoc')
+optdepends=()
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+noextract=("${source[@]##*/}")
+sha256sums=('c0ed3023241a27286cd8f7ce9388d456d39517cb65647565027abdb50f8d99f5')
+
+package() {
+ npm install -g --prefix "$pkgdir/usr" "${source[@]##*/}"
+}
+
+# vim:set ts=2 sw=2 et: