summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaan Genç2015-07-10 15:20:36 +0300
committerKaan Genç2015-07-10 15:20:36 +0300
commit14fbaf388fee315ec01b369ad9606d0af47d48cd (patch)
treeadf60e2549ef6a506f2bf1d55dafe00304704f5c /PKGBUILD
downloadaur-14fbaf388fee315ec01b369ad9606d0af47d48cd.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbd493bc7520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Kaan Genç <SeriousBug at gmail dot com>
+
+_npmname=pulp
+pkgname=nodejs-$_npmname
+pkgver=4.0.2
+pkgrel=1
+pkgdesc='A build system and package manager for PureScript projects.'
+arch=('any')
+url='https://github.com/bodil/pulp'
+license=('LGPL3')
+depends=('npm')
+source=("http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+noextract=($_npmname-$pkgver.tgz)
+md5sums=('0727f690a584ce58468883b34030306b')
+
+package() {
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}