summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugues Chabot2016-10-04 22:15:17 -0400
committerHugues Chabot2016-10-04 22:18:02 -0400
commit2feb9d210c713545112b3383138399ca7f7e9fa3 (patch)
treec2fe6398b1a0a186229e1a16c2c900b35aec42b5 /PKGBUILD
downloadaur-2feb9d210c713545112b3383138399ca7f7e9fa3.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2b73e606caa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hugues Chabot <at google mail>
+_npmname=serverless
+_npmver=1.0.0-rc.2
+pkgname=nodejs-serverless # All lowercase
+pkgver=1.0.0_rc.2
+pkgrel=1
+pkgdesc="Serverless Framework - Build web, mobile and IoT applications with serverless architectures using AWS Lambda, Azure Functions, Google CloudFunctions & more"
+arch=(any)
+url="https://github.com/serverless/serverless#readme"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(ad1c242f2e35dc95948d5c75a6494d8c95c9e253)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: