summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2017-02-13 11:54:24 +0200
committerChristoph Gysin2017-02-13 11:54:24 +0200
commit15ffe16884444c3bd11197151fde8417d4b2032f (patch)
tree903aa81cf753cce20850415a0dd943a105918359 /PKGBUILD
downloadaur-15ffe16884444c3bd11197151fde8417d4b2032f.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..531f9c14d650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+
+pkgname=nodejs-serverless-git
+_pkgname=serverless
+pkgver=v1.6.1.36.g88c9dc88
+pkgrel=1
+pkgdesc="Serverless Framework - Build web, mobile and IoT applications with serverless architectures using AWS Lambda, Azure Functions, Google CloudFunctions & more"
+arch=('any')
+url="https://serverless.com"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+provides=(nodejs-serverless)
+conflicts=(nodejs-serverless)
+source=("git+https://github.com/${_pkgname}/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ local ver="$(git describe --tags)"
+ printf "%s" "${ver//-/.}"
+}
+
+package() {
+ npm \
+ install \
+ --user root \
+ --global \
+ --prefix "${pkgdir}/usr" \
+ --cache "${srcdir}/npm-cache" \
+ "${srcdir}/${_pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: