summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2018-05-27 13:54:40 -0400
committerSolomon Choina2018-05-27 13:54:40 -0400
commitb0d0bc9f7159e89ac3d549e0f3c9543485afa010 (patch)
tree7b7fb755104e58e049aacfcf59fe33f101bdee88 /PKGBUILD
downloadaur-b0d0bc9f7159e89ac3d549e0f3c9543485afa010.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..894f8f52c91a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+
+pkgname=nodejs-shelljs
+pkgver=0.8.2
+pkgrel=1
+pkgdesc="ShellJS - Unix shell commands for Node.js"
+arch=('any')
+url="https://www.npmjs.com/package/shelljs"
+license=('BSD')
+depends=('nodejs')
+makedepends=('npm')
+source=("https://registry.npmjs.org/shelljs/-/shelljs-$pkgver.tgz")
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/shelljs-$pkgver.tgz
+ chmod -R go-w "$pkgdir"/usr
+}
+
+sha256sums=('8ef117fa17983c249db43811880679382d2c8d5fb7e22d08324df469cecd28fd')