summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNikita Volodin [Никита Володин]2016-01-30 23:55:44 -0400
committerNikita Volodin [Никита Володин]2016-01-31 00:02:00 -0400
commit245ae4417364b1afbf3d7aa54e20319b2c793290 (patch)
treef6fe93be1961e33826e0a05e1978c37ee30aa2ec /PKGBUILD
parentaa1c43fa204a13d3ddb6ee9c4b21643d9ba56b60 (diff)
downloadaur-245ae4417364b1afbf3d7aa54e20319b2c793290.tar.gz
feat(PKGBUILD): add license information
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab5d189663be..0152dc2f801c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,19 @@ pkgrel=2
pkgdesc="Private npm repository server"
arch=("any")
url="https://github.com/rlidwka/sinopia"
-license=()
+license=("WTFPL")
depends=("nodejs")
makedepends=("npm")
install=nodejs-sinopia.install
source=("http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz"
"sinopia.service"
- "nodejs-sinopia.install")
+ "nodejs-sinopia.install"
+ "LICENSE")
noextract=("$_npmname-$pkgver.tgz")
sha1sums=("36bf5209356facbf6cef18fa32274d116043ed24"
"a96ee3c3407e70a22bef11d42f0f3b393eefc1ae"
- "9cb284b9f22894a6f2cd465156d9ed9f5c1c8776")
+ "9cb284b9f22894a6f2cd465156d9ed9f5c1c8776"
+ "337ece375beddfdb7392699fd00eb9b3e823d03f")
package() {
cd $srcdir
@@ -28,6 +30,8 @@ package() {
install -Dm644 sinopia.service "$pkgdir/usr/lib/systemd/system/sinopia.service"
install -Dm644 sinopia.service "$pkgdir/usr/lib/systemd/user/sinopia.service"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: