summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-08-05 19:35:57 +0200
committerXZS2016-08-11 19:40:33 +0200
commit84286cfb9b00bcfdec85e5669800b525c73ba6d5 (patch)
tree3fa370cda4dab66e43902ad3022185c9211cb08f /PKGBUILD
parent41b4a9aeee07273533a0bcd49e277b4412b46b43 (diff)
downloadaur-84286cfb9b00bcfdec85e5669800b525c73ba6d5.tar.gz
support arbitrary integrity checks
The git-makepkg-templates switched to dynamic adaptation to integrity checks chosen in makepkg.conf. [1] The default checksums chosen reflect recommendations from the Arch Linux Wiki and manual pages. [2] [1]: https://github.com/dffischer/git-makepkg-templates/commit/e84d04b [2]: https://aur.archlinux.org/cgit/aur.git/commit/?h=git-makepkg-templates-git&id=c2ccaaa
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71f989e205ff..e1783aaf6f08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,11 @@ optdepends=()
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-md5sums+=('SKIP')
+for integ in $(get_integlist)
+do
+ typeset -n array="${integ}sums"
+ array+=('SKIP')
+done
provides+=("$_gitname=$pkgver")
conflicts+=("$_gitname")