summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:34:05 +0200
committerDaniel Nagy2015-06-08 20:34:05 +0200
commit4f8bd3fc79810973f6bedee186fdf1044c3b1a50 (patch)
treedeafdbdacb3519a2bb08c66ca8b6b14ce17e978b /PKGBUILD
downloadaur-4f8bd3fc79810973f6bedee186fdf1044c3b1a50.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98e75f6f518f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Nodejitsu Inc. <info@nodejitsu.com>
+# Contributor: indexzero <charlie.robbins@gmail.com>
+# Contributor: mmalecki <me@mmalecki.com>
+# Contributor: chjj <chjjeffrey@gmail.com>
+# Contributor: V1 <info@3rd-Eden.com>
+
+_npmname=winston
+_npmver=0.9.0
+pkgname=nodejs-winston # All lowercase
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="A multi-transport async logging library for Node.js"
+arch=(any)
+url="https://github.com/flatiron/winston"
+license=("MIT")
+depends=('nodejs' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=('b5726e6c42291e305e36286ce7ae9f3b74a527a8')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: