summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShrinivas Vishnu Kumbhar2021-03-18 13:08:34 +0530
committerShrinivas Vishnu Kumbhar2021-03-18 13:08:34 +0530
commit3e4b171a4df0c5a4f4b262ff04b098d28e47c5b3 (patch)
tree5da5382bd6ed012ae55838401f7258583385bd31 /PKGBUILD
parent7a2d93976e3defd1fb4ab125ac47b50ef6a83bd6 (diff)
downloadaur-3e4b171a4df0c5a4f4b262ff04b098d28e47c5b3.tar.gz
fix pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 21 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 544027aa362a..b96b488670be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,32 @@
# Maintainer: Librewish <librewish AT gmail.com>
-
-_pkgname=nohang
-pkgname=${_pkgname}
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=nohang
pkgver=0.2.0
pkgrel=1
pkgdesc="A sophisticated low memory handler."
arch=('any')
url="https://github.com/hakavlad/nohang"
license=('MIT')
-source=(
- "$pkgname::https://github.com/hakavlad/nohang/archive/v${pkgver}.tar.gz"
-)
-md5sums=('SKIP')
-depends=(
- 'python'
-)
-
-conflicts=("${_pkgname}")
-backup=(
- 'etc/nohang/nohang.conf'
- 'etc/nohang/nohang-desktop.conf'
- 'etc/logrotate.d/nohang'
-)
+depends=('python' 'systemd')
+makedepends=('git')
+optdepends=('libnotify: notification server'
+ 'logrotate: logrotate support'
+ 'sudo: if nohang started with UID=0')
+backup=("etc/$pkgname/$pkgname.conf"
+ "etc/$pkgname/$pkgname-desktop.conf"
+ "etc/logrotate.d/$pkgname")
+source=("git+https://github.com/hakavlad/nohang.git#tag=v$pkgver")
+sha256sums=('SKIP')
package() {
- cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
+ cd "$srcdir/$pkgname"
make \
- DESTDIR="${pkgdir}" \
- PREFIX="/usr" \
- SBINDIR="/usr/bin" \
- SYSCONFDIR="/etc" \
- SYSTEMDUNITDIR="/usr/lib/systemd/system" \
- install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ DESTDIR="$pkgdir" \
+ PREFIX='/usr' \
+ SBINDIR='/usr/bin' \
+ SYSCONFDIR='/etc' \
+ SYSTEMDUNITDIR='/usr/lib/systemd/system' \
+ base units
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}