summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Friedrich2017-08-12 15:54:12 +0200
committerOliver Friedrich2017-08-12 15:54:12 +0200
commit92df595fca132fdde5ed58245b32e12571aafa97 (patch)
treea8231af45769d105aa841bbdbd2a3ac0d1f21a16 /PKGBUILD
downloadaur-92df595fca132fdde5ed58245b32e12571aafa97.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7482fdc89b28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Oliver Friedrich <olifriedrich@gmail.com>
+
+pkgname=noise-repellent
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="An lv2 plugin for broadband noise reduction."
+arch=('i686' 'x86_64')
+url="https://github.com/lucianodato/noise-repellent"
+license=('GPL')
+groups=('lv2-plugins')
+depends=('fftw' 'lv2')
+makedepends=('gcc')
+optdepends=('jack: standalone jack client'
+ 'ardour: intended use')
+source=("https://github.com/lucianodato/noise-repellent/archive/$pkgver.tar.gz")
+md5sums=('67fd693e80f86a09c2678f13ef1c2958')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}