summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Anderson2020-06-28 09:57:46 -0500
committerEric Anderson2020-06-28 09:57:46 -0500
commit81a9b1ec5932690b5d3e50e89621e2d4f6676588 (patch)
treedebbcdab3bf481f3c9f7bcab66a7551235a42987 /PKGBUILD
downloadaur-nomarch.tar.gz
Initial version, 1.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f41a6543ada9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Eric Anderson <ejona86@gmail.com>
+
+pkgname=nomarch
+pkgver=1.4
+pkgrel=1
+pkgdesc="Extract, list, and test files from the old '.arc' archive format"
+arch=('x86_64')
+url="http://www.svgalib.org/rus/nomarch.html"
+license=('GPL2')
+depends=('glibc')
+source=("https://ibiblio.org/pub/Linux/utils/compress/$pkgname-$pkgver.tar.gz")
+sha256sums=(fe20da34e0d3ba0cf6388701f44ac22224cf65130ddbc5fcbc27bc4949a6e1ad)
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i 's/-o nomarch/-o nomarch $(LDFLAGS)/' Makefile
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr" MANDIR="$pkgdir/usr/share/man/man1" install
+}