summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-07-25 09:47:06 -0500
committerLuis Martinez2022-07-25 09:47:06 -0500
commitab9df248c2950a39be101b3ef4bcae21e5fe536d (patch)
tree5594013575a23d4d917e458eb606574f943a70e2 /PKGBUILD
parentcea149c57f239056c342b1737717753b7294329e (diff)
downloadaur-ab9df248c2950a39be101b3ef4bcae21e5fe536d.tar.gz
update to 1.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6c3f91a59ee..c36bef3d49c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: yaa110 <yaa110@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: yaa110 <yaa110@gmail.com>
pkgname=nomino-bin
-_pkgname=nomino
-pkgver=0.4.2
+_pkgname="${pkgname%-bin}"
+pkgver=1.2.1
pkgrel=1
+pkgdesc='Batch rename utility for developers'
arch=('x86_64')
url="https://github.com/yaa110/nomino"
-license=("MIT")
-
-pkgdesc='Batch rename utility for developers'
-
-source=("LICENSE::https://raw.githubusercontent.com/yaa110/$_pkgname/master/LICENSE-MIT")
-source_x86_64=("https://github.com/yaa110/$_pkgname/releases/download/$pkgver/$_pkgname-linux-64bit")
-sha512sums=("169b314c09dffe76c8bf31929a61e58358c66516c17629cb257e0d44101b78d3949ee6d9951bb813cd6348d8626a0c8f638f6f874db446dce87cfa1de24d39ba")
-sha512sums_x86_64=("0cd43401476060dca6d462fc5028f61f4ac062cc3aac828e30da895b9ebfafbe5acb3d04184271cb66941ee58a6d10339bdb7f2ae8f087cff062938fa08c6222")
+license=('Apache' 'MIT')
depends=('gcc-libs')
-conflicts=('nomino')
-provides=('nomino')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=('LICENSE')
+source_x86_64=("$_pkgname-$pkgver-x86_64::$url/releases/download/$pkgver/$_pkgname-linux-64bit")
+sha256sums=('c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f')
+sha256sums_x86_64=('bbbcefb8a8f1ece37c66f20d901725069fcbed8f5e3664467992ae2ec8296bb6')
package() {
- install -Dm755 "$srcdir/$_pkgname-linux-64bit" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D "$_pkgname-$pkgver-$CARCH" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-