summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-12-19 22:05:59 -0600
committerLuis Martinez2021-12-19 22:05:59 -0600
commit7c30f399fb58b8402bfcbb42bdd83e7e465be15b (patch)
tree18e50bf3078e61af97779cce3d767e7fcc72d569 /PKGBUILD
downloadaur-7c30f399fb58b8402bfcbb42bdd83e7e465be15b.tar.gz
inital commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6897045be2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=nordic-wallpapers-git
+pkgver=r50.700ec61
+pkgrel=1
+pkgdesc="Wallpaper collection using the Nord color palette"
+arch=('any')
+url="https://github.com/linuxdotexe/nordic-wallpapers"
+license=('MIT')
+makedepends=('git')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm644 wallpapers/* -t "$pkgdir/usr/share/backgrounds/$pkgname/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
+