summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Morr2015-06-24 22:27:01 +0200
committerSebastian Morr2015-06-24 22:27:01 +0200
commit3bf1d432dda9251b061a4fd21b838acdc98dde1f (patch)
treea51728b86f2ca55647dc02b079ac8f97547b79ca /PKGBUILD
downloadaur-3bf1d432dda9251b061a4fd21b838acdc98dde1f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25d859678e30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sebastian Morr <sebastian@morr.cc>
+
+pkgname=nordlicht-git
+_gitname=nordlicht
+pkgver=20150624
+pkgrel=1
+pkgdesc="Creates colorful moviebarcodes from video files, comes with a shared C library"
+arch=('i686' 'x86_64')
+url="http://github.com/nordlicht/nordlicht"
+license=('GPL')
+depends=('ffmpeg' 'popt')
+makedepends=('git' 'cmake' 'help2man')
+provides=('nordlicht')
+conflicts=('nordlicht')
+source=('git+https://github.com/nordlicht/nordlicht')
+sha1sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_gitname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir" install
+}