summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrega Vrbančič2020-08-03 18:37:42 +0200
committerGrega Vrbančič2020-08-03 18:37:42 +0200
commit4d4e591ae77a7a41be6d3728dd44c60f8cc8aaac (patch)
tree5e1ff9a0827d386787200696fd6f83fa5b9e804e /PKGBUILD
downloadaur-4d4e591ae77a7a41be6d3728dd44c60f8cc8aaac.tar.gz
Add nordugrid-arc version 6.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12ce2a3f1a90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grega Vrbančič <grega.vrbancic@gmail.com>
+
+pkgname=nordugrid-arc
+pkgver=6.7.0
+pkgrel=1
+pkgdesc="The Advanced Resource Connector (ARC) middleware, developed by the NorduGrid Collaboration."
+arch=('x86_64')
+url="http://www.nordugrid.org/arc/arc6"
+license=('Apache 2.0')
+depends=('python2' 'globus-toolkit')
+makedepends=()
+provides=()
+source=(http://download.nordugrid.org/packages/$pkgname/releases/$pkgver/src/$pkgname-$pkgver.tar.gz{,.asc})
+sha256sums=('156265ff7dcebe94e61e850ce11584ad70ee25f885bba9277810d8ed2e1ab408'
+ 'SKIP')
+validpgpkeys=('2BD6CDCE625B9FD35F25621DE8C1DBE17CE871D5')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --disable-swig --with-python=python2
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}