summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Glorioz2018-03-25 01:57:40 +0100
committerFlorian Glorioz2018-03-25 01:57:40 +0100
commit7327f3aae029880b5088976d86173b5818d9f834 (patch)
tree3e8431642f3feef4de43ce2627ea2ff1346ec1bf /PKGBUILD
downloadaur-7327f3aae029880b5088976d86173b5818d9f834.tar.gz
Add v1 of pkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3be3c664753b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Florian Glorioz <florian.glorioz@epitech.eu>
+pkgname=normez
+pkgver=r121.617849d
+pkgrel=1
+pkgdesc="Coding-style checker for Epitech students."
+arch=('any')
+url="https://github.com/ronanboiteau/NormEZ"
+license=('MIT')
+groups=()
+depends=('ruby' 'git')
+source=('https://github.com/ronanboiteau/NormEZ/archive/master.zip')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ git clone https://github.com/ronanboiteau/NormEZ.git "$pkgname"
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 NormEZ.rb "${pkgdir}/usr/bin/${pkgname}"
+} \ No newline at end of file