summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRenato Molnar2022-09-03 12:44:19 +0200
committerRenato Molnar2022-09-03 12:44:19 +0200
commit95a1c3be3bb2c84d370faa77e75e187bd623ddd3 (patch)
treebbffd2de1f260f63c8892a3fb2b9a93ddacb69f4 /PKGBUILD
parentb4a26de79cff11942ecb4cadaee3a4a422195bca (diff)
downloadaur-95a1c3be3bb2c84d370faa77e75e187bd623ddd3.tar.gz
Fix for bug where the changes weren't saved
Refactored start script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 18 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 240edfed0710..b754c0ada072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,19 @@
-# Maintainer: Renato Molnar <m dot renato93 at gmail dot com>
+# Maintainer: Renato Molnar <renato dot molnar at posteo dot net>
+
+# If you want to package the 64bit version, you need to uncomment the following line:
+#_arch=x64
+
+if [[ "${_arch}" == x64 ]]; then
+ winarch='64'
+else
+ winarch='32'
+fi
pkgname=notepadpp
_pkgname=notepad-plus-plus
pkgver=8.4.4
-pkgrel=1
-pkgdesc="A free source code editor for Windows"
+pkgrel=2
+pkgdesc="A free source code editor for Windows - (${winarch}-bit)"
arch=('x86_64')
url="https://${_pkgname}.org/"
license=('GPL2')
@@ -16,28 +25,17 @@ conflicts=('notepadpp-win32' 'notepadpp-win64')
source=(notepadpp
notepadpp.desktop
notepadpp.png
- "https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.zip"
- "https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.x64.zip")
+ "npp.${pkgver}.32.zip::https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.zip"
+ "npp.${pkgver}.64.zip::https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.x64.zip")
-sha256sums=('d4352139a459f532b807262b5b1933c98142fc772de713abc39e6073d291b200'
+sha256sums=('3e68329f18c46a240b8c852ccfe291b78ae0c37b692f090a1b2e379892415576'
'a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238'
'04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad'
'b6c5c11518a7de1cb3ab095506ceb5a69520b19046e3e864cbfeee329fe8a250'
'2a07301ea6fe16cb7d814653239d80722b8b432313249720f6856aec070fded0')
-noextract=("npp.${pkgver}.bin.zip"
- "npp.${pkgver}.bin.x64.zip")
-
-# If you want to package the 64bit version, you need to uncomment the following line:
-#_arch=x64
-
-if [[ "${_arch}" == x64 ]]; then
- _arch='.x64'
- pkgdesc+=" (64-bit)"
-else
- _arch=''
- pkgdesc+=" (32-bit)"
-fi
+noextract=("npp.${pkgver}.32.zip"
+ "npp.${pkgver}.64.zip")
options=('!strip')
@@ -45,7 +43,7 @@ package() {
install -d -m755 "${pkgdir}/usr/share/${pkgname}"
- unzip "${srcdir}/npp.${pkgver}.portable${_arch}.zip" -d "${pkgdir}/usr/share/${pkgname}"
+ unzip "${srcdir}/npp.${pkgver}.${winarch}.zip" -d "${pkgdir}/usr/share/${pkgname}"
rm -rf "${pkgdir}/usr/share/${pkgname}/updater" \
"${pkgdir}/usr/share/${pkgname}/license.txt" \